Added ags ebuild
This commit is contained in:
parent
2f0adf703a
commit
d660a5fe45
5 changed files with 144 additions and 0 deletions
2
gui-apps/ags/Manifest
Normal file
2
gui-apps/ags/Manifest
Normal file
|
@ -0,0 +1,2 @@
|
|||
DIST ags-1.8.2-node_modules.tar.gz 18888810 BLAKE2B bf118c47e08c5075502c01cbdcb68189c4964ec32413a298fa9abaaf5634ccf3cc94251de5dc38c1913c66ba3346cd60f4d0a1179dfec571b6ceb269f0a6acc2 SHA256 ac31c171eb218780a6146527a5a9a5081ac06833c53c9d44f8ed0dc01e0e6f2c SHA512 814acad890be748d04f7e28ea6c7a8321edac907c2729c7f4966a8bb24bccad69684d570bc4b9f6148361f8ce5d1ef8306677ef781598467c6a06b765ac974ca
|
||||
DIST ags-1.8.2.tar.gz 435232 BLAKE2B 9b7c7cbe652df76282d9dc11dd49d09ab1fb962e45fec3f3a849b161abd3e8f287f14a72cb7ac85df7f65fea748e4b1546568684eb830ce0382f2f4977d57564 SHA256 ea0a706bef99578b30d40a2d0474b7a251364bfcf3a18cdc9b1adbc04af54773 SHA512 4ed3f4b4da9c8bbd045ab3cd455b24768bc8807fa9a215a5b788b6319edd72c76cb9fe6d3e3cf82068e43bf3463d5025cfb86eba78b93bc481d95e2e4ed4552d
|
57
gui-apps/ags/ags-1.8.2-r3.ebuild
Normal file
57
gui-apps/ags/ags-1.8.2-r3.ebuild
Normal file
|
@ -0,0 +1,57 @@
|
|||
# Copyright 1999-2024 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=8
|
||||
|
||||
inherit meson
|
||||
|
||||
DESCRIPTION="A customizable and extensible shell"
|
||||
HOMEPAGE="https://aylur.github.io/ags-docs/"
|
||||
|
||||
SRC_URI="
|
||||
https://github.com/Aylur/ags/releases/download/v${PV}/ags-v${PV}.tar.gz -> ${P}.tar.gz
|
||||
https://github.com/Aylur/ags/releases/download/v${PV}/node_modules-v${PV}.tar.gz -> ${P}-node_modules.tar.gz
|
||||
"
|
||||
|
||||
S="${WORKDIR}/${PN}"
|
||||
LICENSE="GPL-3+"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64"
|
||||
|
||||
DEPEND="
|
||||
dev-libs/gjs
|
||||
dev-libs/glib:2
|
||||
dev-libs/libffi:=
|
||||
dev-libs/libpcre2:=
|
||||
gui-libs/gtk-layer-shell[introspection]
|
||||
media-libs/flac:=
|
||||
media-libs/libogg
|
||||
media-libs/libpulse
|
||||
media-libs/libsndfile
|
||||
media-libs/libvorbis
|
||||
media-libs/opus
|
||||
media-sound/lame
|
||||
media-sound/mpg123-base
|
||||
net-libs/libasyncns
|
||||
sys-apps/dbus
|
||||
sys-libs/pam
|
||||
sys-libs/zlib
|
||||
x11-libs/gtk+:3
|
||||
x11-libs/libXau
|
||||
x11-libs/libxcb:=
|
||||
x11-libs/libXdmcp
|
||||
"
|
||||
|
||||
BDEPEND="
|
||||
dev-lang/typescript
|
||||
dev-libs/gobject-introspection
|
||||
"
|
||||
|
||||
RDEPEND="${DEPEND}"
|
||||
|
||||
PATCHES=( "${FILESDIR}/${P}-fix-tsc-call.patch" )
|
||||
|
||||
src_prepare() {
|
||||
default
|
||||
ln -sr "${WORKDIR}/node_modules" "${S}/node_modules" || die
|
||||
}
|
34
gui-apps/ags/files/ags-1.8.2-fix-tsc-call.patch
Normal file
34
gui-apps/ags/files/ags-1.8.2-fix-tsc-call.patch
Normal file
|
@ -0,0 +1,34 @@
|
|||
From a756f5266a97e4cdf0550283ec50210de58fbde3 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Matt=C3=A9o=20Rossillol=E2=80=91=E2=80=91Laruelle?=
|
||||
<beatussum@protonmail.com>
|
||||
Date: Mon, 17 Jun 2024 13:39:13 +0200
|
||||
Subject: [PATCH] fix `tsc` call
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
In order to allow the meson build directory to be in another repertory (the
|
||||
default behavior of the `meson` eclass), `--project` has to be added to the
|
||||
`tsc` call.
|
||||
|
||||
Signed-off-by: Mattéo Rossillol‑‑Laruelle <beatussum@protonmail.com>
|
||||
---
|
||||
src/meson.build | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/meson.build b/src/meson.build
|
||||
index e25ab8c..a8bbfb3 100644
|
||||
--- a/src/meson.build
|
||||
+++ b/src/meson.build
|
||||
@@ -6,7 +6,7 @@ typescript = custom_target(
|
||||
input: files( 'main.ts' ),
|
||||
build_by_default: true,
|
||||
build_always_stale: true,
|
||||
- command: [ tsc, '--outDir', tsc_out ],
|
||||
+ command: [ tsc, '--outDir', tsc_out, '--project', meson.source_root() ],
|
||||
output: ['tsc-output'],
|
||||
)
|
||||
|
||||
--
|
||||
2.44.2
|
||||
|
50
gui-apps/ags/metadata.xml
Normal file
50
gui-apps/ags/metadata.xml
Normal file
|
@ -0,0 +1,50 @@
|
|||
<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
|
||||
<pkgmetadata>
|
||||
<maintainer type="person">
|
||||
<email>beatussum@protonmail.com</email>
|
||||
<name>Mattéo Rossillol‑‑Laruelle</name>
|
||||
</maintainer>
|
||||
<longdescription>
|
||||
This is a library built for <pkg>dev-libs/gjs</pkg> to allow
|
||||
defining <pkg>x11-libs/gtk+</pkg> widgets in a declarative way.
|
||||
It also provides services and other utilities to interact with
|
||||
the system so that these widgets can have functionality.
|
||||
<pkg>dev-libs/gjs</pkg> is a JavaScript runtime built on
|
||||
Firefox's SpiderMonkey JavaScript engine and the GNOME platform
|
||||
libraries, the same runtime <pkg>gui-libs/gtk-layer-shell</pkg>
|
||||
runs on.
|
||||
|
||||
It was heavily inspired by EWW.
|
||||
|
||||
Currently, only <pkg>dev-libs/wayland</pkg> is supported, but
|
||||
it also works on X11, see #19.
|
||||
</longdescription>
|
||||
<longdescription lang="fr">
|
||||
Il s'agit d'une bibliothèque construite pour
|
||||
<pkg>dev-libs/gjs</pkg> qui permet de définir des widgets
|
||||
<pkg>x11-libs/gtk+</pkg> de façon déclarative. Il fournit
|
||||
également des services et d'autres utilitaires pour interagir
|
||||
avec le système afin que ces widgets puissent avoir des
|
||||
fonctionnalités. <pkg>dev-libs/gjs</pkg> est un moteur
|
||||
d'exécution JavaScript construit sur le moteur JavaScript
|
||||
SpiderMonkey de Firefox et les bibliothèques de la plateforme
|
||||
GNOME. Il s'exécute en même temps que
|
||||
<pkg>gui-libs/gtk-layer-shell</pkg>.
|
||||
|
||||
Elle a été fortement inspirée par EWW.
|
||||
|
||||
Actuellement, seul <pkg>dev-libs/wayland</pkg> est supporté,
|
||||
mais elle fonctionne également sur X11, voir #19.
|
||||
</longdescription>
|
||||
<upstream>
|
||||
<maintainer status="active">
|
||||
<name>Aylur</name>
|
||||
<email>demstof@gmail.com</email>
|
||||
</maintainer>
|
||||
<changelog>https://raw.githubusercontent.com/Aylur/ags/main/CHANGELOG.md</changelog>
|
||||
<doc>https://aylur.github.io/ags-docs/</doc>
|
||||
<bugs-to>https://github.com/Aylur/ags/issues/</bugs-to>
|
||||
<remote-id type="github">Aylur/ags</remote-id>
|
||||
</upstream>
|
||||
</pkgmetadata>
|
1
gui-apps/ags/readme.txt
Normal file
1
gui-apps/ags/readme.txt
Normal file
|
@ -0,0 +1 @@
|
|||
These templates are from the Hyprland-overlay: https://github.com/beatussum/hyprland-overlay/tree/main
|
Loading…
Reference in a new issue